Infotainment / engine start issues - Kia K900 Forum
 
LinkBack Thread Tools
post #1 of 2 Old 01-13-2022, 09:34 PM Thread Starter
Junior Member
 
Join Date: Dec 2021
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Default Infotainment / engine start issues

Hello all. I have an issue with my infotainment system. The screen flickers all day. It may stop for a couple of minutes but is aggravating as the dealership keeps saying they cannot see this happen. Even though it was there for a total of six days. The driver picked the car up saw the screen flicker. The driver that dropped it off pointed it out to me. Funny how within the car being at the dealership Courtesy Kia Brandon Florida that long none of the technicians saw it happen so Kia says they cannot do anything about it.

Anybody else seeing issues with the 2019 infotainment system? A little embarrassing as you are driving along and cannot make out what is on your screen as it flickers continually. Any solutions? One other thing. Any 2019 or newer ones that start and the engine ticks heavily as though you have lifter issues? I was told this normal. Again 65K car that starts and sounds like it is over 100K miles when I only have 9556 miles on it. Help?
BigHue is offline  
post #2 of 2 Old 01-20-2022, 08:14 PM
Junior Member
 
Join Date: Mar 2021
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Default

Quote:
Originally Posted by BigHue View Post
Hello all. I have an issue with my infotainment system. The screen flickers all day. It may stop for a couple of minutes but is aggravating as the dealership keeps saying they cannot see this happen. Even though it was there for a total of six days. The driver picked the car up saw the screen flicker. The driver that dropped it off pointed it out to me. Funny how within the car being at the dealership Courtesy Kia Brandon Florida that long none of the technicians saw it happen so Kia says they cannot do anything about it.

Anybody else seeing issues with the 2019 infotainment system? A little embarrassing as you are driving along and cannot make out what is on your screen as it flickers continually. Any solutions? One other thing. Any 2019 or newer ones that start and the engine ticks heavily as though you have lifter issues? I was told this normal. Again 65K car that starts and sounds like it is over 100K miles when I only have 9556 miles on it. Help?
Classic that the car doesn't do the problem while at the dealership. It's as if it knows it's being watched. Try seeing if you can get a recording of it happening. This has helped me in the past with other problems. I have not had this issues. As for the ticking, my past two Kias (Sorento and Optima) both did that at cold starts only. If this is at every start definitely concerning.

_______________________
Lakestone VIP Package 2019
josh300c is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome