K900 no audio -- just stopped no sound - Kia K900 Forum
 
LinkBack Thread Tools
post #1 of 9 Old 11-16-2015, 10:17 PM Thread Starter
Junior Member
 
Join Date: Jan 2015
Location: Lake Mary, FL
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Default K900 no audio -- just stopped no sound

This has happened 3 or 4 times now. Up until now I would turn off the car and turn back on to correct the problem, But tonight that did not work. Anyone else having this issue.
MBono is offline  
post #2 of 9 Old 11-16-2015, 10:40 PM
Super Moderator
 
Gene's Avatar
 
Join Date: Jul 2015
Posts: 514
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 98 Post(s)
Garage
Default

Not on the K900 but I did have that problem on the Cadenza.
Not just the radio but the air, power windows, power seats, and window wipers.
Traded that Cadenza in for a K900. no issues so far. except for the tires starting to wobble.
after 13,000 miles. KIA replaced them free of charge for me. No help at all on the Cadenza
Gene is offline  
post #3 of 9 Old 11-22-2015, 02:50 PM
Member
 
Join Date: Oct 2015
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Default

Hello new to the forums. I got my 2015 KIA K900 early this year, the first people in western Canada to have one(so the dealer said). I was also the first person to no audio in a k900. My dealership had my car for 3 weeks, called the best KIA techs in Canada/USA/South Korea. They replaced the amp and head unit and nothing. It turned out to be a loose pin in a connector, the problem went away but came back the tech found another loose pin. My audio is back, enjoy my car(just parked it for winter). Take it to your dealership and have them call Go KIA South in Edmonton AB, Canada so your K900 could be fixed quick.
socaboy23 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 Old 11-22-2015, 09:44 PM
Senior Member
 
Join Date: Jun 2015
Location: Vancouver BC
Posts: 238
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Garage
Default

Quote:
Originally Posted by socaboy23 View Post
Hello new to the forums. I got my 2015 KIA K900 early this year, the first people in western Canada to have one(so the dealer said). I was also the first person to no audio in a k900. My dealership had my car for 3 weeks, called the best KIA techs in Canada/USA/South Korea. They replaced the amp and head unit and nothing. It turned out to be a loose pin in a connector, the problem went away but came back the tech found another loose pin. My audio is back, enjoy my car(just parked it for winter). Take it to your dealership and have them call Go KIA South in Edmonton AB, Canada so your K900 could be fixed quick.
Why dont you post your pictures . I got mine from Kia Richmond BC and they have so far provided excellent service . Do you go down south for the winter or drive a truck ?




Larry
2015 k900 V6 Premium Edition Metallic Silver
funnyman7915 is offline  
post #5 of 9 Old 11-23-2015, 12:19 AM
Member
 
Join Date: Oct 2015
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Default

Quote:
Originally Posted by funnyman7915 View Post
Why dont you post your pictures . I got mine from Kia Richmond BC and they have so far provided excellent service . Do you go down south for the winter or drive a truck ?
Pictures? I never did the work, the good folks of Go KIA South did all the work. That's why I said for him/her to get their dealership to give mine a call. I wish I could head south for the winter but cant. Since the K900 is RWD I just parked it and got my self a $1500 winter Honda. Its nice hearing more people are getting the K900 in Canada

2015 KIA K900 V6 Luxury White
socaboy23 is offline  
post #6 of 9 Old 11-23-2015, 12:21 PM
Senior Member
 
Join Date: Jun 2015
Location: Vancouver BC
Posts: 238
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Garage
Default

Quote:
Originally Posted by socaboy23 View Post
Pictures? I never did the work, the good folks of Go KIA South did all the work. That's why I said for him/her to get their dealership to give mine a call. I wish I could head south for the winter but cant. Since the K900 is RWD I just parked it and got my self a $1500 winter Honda. Its nice hearing more people are getting the K900 in Canada
New members generally provide pictures of their car sort of traditional Thankfully in Vancouver we don't get Edmonton's cold and snow but the K900 has snow mode and I purchased Falken snow tires at Canada 1010 tires for less than a grand installed all in .In the old days all cars were rear wheel drive and we managed to get through the snow with only two snow tires on the rear let alone 4 snow tires When I get our first snow hopefully never I will report how my snow tires performed but so far I don't hear them and the performance in the rain, and we get some pretty fierce rain storms ,have been superb. . Dry [performance unless you new I had them on you wouldn't feel the difference.




Larry
2015 k900 V6 Premium Edition Metallic Silver
funnyman7915 is offline  
post #7 of 9 Old 11-23-2015, 03:03 PM
Member
 
Join Date: Oct 2015
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Default

Quote:
Originally Posted by funnyman7915 View Post
New members generally provide pictures of their car sort of traditional Thankfully in Vancouver we don't get Edmonton's cold and snow but the K900 has snow mode and I purchased Falken snow tires at Canada 1010 tires for less than a grand installed all in .In the old days all cars were rear wheel drive and we managed to get through the snow with only two snow tires on the rear let alone 4 snow tires When I get our first snow hopefully never I will report how my snow tires performed but so far I don't hear them and the performance in the rain, and we get some pretty fierce rain storms ,have been superb. . Dry [performance unless you new I had them on you wouldn't feel the difference.
Snow Mode I found didn't do much(helps on take off), plus I have another vehicle that I can use during winter. My first car was a 88 Mustang(RWD), I just don't want to drive the K900 in winter. They do a very bad job on clearing the roads in Edmonton, and a lot of bad drivers doesn't help. I'll upload some pics once I take them off my phone.

2015 KIA K900 V6 Luxury White
socaboy23 is offline  
post #8 of 9 Old 11-23-2015, 03:42 PM
Senior Member
 
Join Date: Jun 2015
Location: Vancouver BC
Posts: 238
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Garage
Default

Quote:
Originally Posted by socaboy23 View Post
Snow Mode I found didn't do much(helps on take off), plus I have another vehicle that I can use during winter. My first car was a 88 Mustang(RWD), I just don't want to drive the K900 in winter. They do a very bad job on clearing the roads in Edmonton, and a lot of bad drivers doesn't help. I'll upload some pics once I take them off my phone.
Those bad drivers must all be from the lower mainland because we have the worst drivers in snow imaginable.I would say more than half the drivers maybe more dont buy snows and rely on "all seasons" which as we know are really three seasons




Larry
2015 k900 V6 Premium Edition Metallic Silver
funnyman7915 is offline  
post #9 of 9 Old 11-23-2015, 03:48 PM
Member
 
Join Date: Oct 2015
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Default

Quote:
Originally Posted by funnyman7915 View Post
Those bad drivers must all be from the lower mainland because we have the worst drivers in snow imaginable.I would say more than half the drivers maybe more dont buy snows and rely on "all seasons" which as we know are really three seasons
Yes, alot of people here thinks all seasons for winter. I am seeing more and more winter tires on cars now but, those SUV and pick-ups drivers think that that AWD and 4X4 gives them magical powers in the winter.

2015 KIA K900 V6 Luxury White
socaboy23 is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome