Kia K900 Forum - View Single Post - Kia K900 3.0 K Emblems - K5 Optima Store
View Single Post
post #10 of Old 11-13-2015, 08:32 PM
FunonH20
Junior Member
 
Join Date: Nov 2015
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Default

This evening I installed the 7 piece chrome set with faux carbon fiber from K5 Optima. The hood and trunk are chrome plastic with a black carbon fiber looking (?) sticker in the middle. The front and rear look okay at 50' but the closer you get the cheaper they look.

The rim center caps and steering wheel are very thin aluminum. The black on these is not a sticker. I am guessing it is an enamel or something.

The 3M adhesive for the center caps came all the way to the edge of the cap. Doing a dry fit you can see the thick 3M adhesive all around the cap. I took a razor and back cut the adhesive so the cap fits closer. While pressing one of them in place I pushed a tad too hard and it dented in slightly. They look ok.

The steering wheel was last to be installed. This, like the front and back, cannot be dry fitted. There is no going back after you pry off and destroy the KIA emblem.

Oh holy @#%*& the Mrs is a livid as I am. I took what was an excellent, top quality leather wheel and turn it into what looks like a bird S#@T right in the center of it. We are headed to the dealer first think in the morning to have them order whatever it takes to get it back to factory. The thin aluminum emblem also uses the thick 3M adhesive which if installed as delivered would also show all around the emblem. Again I back cut the adhesive around the perimeter and stuck it in place.The emblem has a slight cup shape but it drastically short of tucking backing into steering wheel for a neat fit light the factory. The 3M holds it so far off that you can see a huge gap all the way around the emblem.

You don't have too say it....$70
Attached Images
File Type: jpg IMG_0985 copy.jpg (340.3 KB, 22 views)

David
Charlotte, NC
FunonH20 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome