EPB stuck on - K900 Having to be towed now.. - Kia K900 Forum
 
LinkBack Thread Tools
post #1 of 10 Old 06-14-2016, 12:42 PM Thread Starter
Senior Member
 
K5 Optima Store's Avatar
 
Join Date: Jun 2014
Location: Los Angeles, CA
Posts: 190
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage
Default EPB stuck on - K900 Having to be towed now..

Well out of the blue this morning my 2015 K900 cannot move whatsoever. The electronic parking brake is engaged and is lit up in yellow on the dashboard, and I cannot release the brake no matter what I do.

The car cannot move even when put in neutral because the electronic parking brake has been applied and cannot be released. So looks like we're having to have the car towed to the dealership today. Anyone ever heard of anything like this before?
K5 Optima Store is offline  
post #2 of 10 Old 06-14-2016, 02:33 PM
Super Moderator
 
Gene's Avatar
 
Join Date: Jul 2015
Posts: 365
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 83 Post(s)
Garage
Default

Mine always lights red. doesn't release until brake is pressed and put in drive or reverse.
No way to release parking brake other than that.
Never had light go to yellow, sounds like a malfunction.
mine doesn't release in neutral only drive or reverse.
Never had a problem with mine.
Make sure tow outfit doesn't try to drag car on to carrier with brake on.
Your still under warranty right?

Last edited by Gene; 06-14-2016 at 02:35 PM.
Gene is offline  
post #3 of 10 Old 06-14-2016, 03:19 PM Thread Starter
Senior Member
 
K5 Optima Store's Avatar
 
Join Date: Jun 2014
Location: Los Angeles, CA
Posts: 190
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage
Default

Yeah what you are describing above is the normal functionality on how the electronic parking brake works.

This is 100% a malfunction of the electronic parking brake module itself.

The tow truck driver had to use go jacks or skates in order to lift the rear wheels to get it onto the tow truck.

Definitely still under warranty and I have already spoken to the service manager who confirmed that he has seen this issue on a K900 but that it isn't very common. He mentioned that once the electronic parking brake malfunction it's similar to a boat dropping an anchor. There is absolutely nothing that can be done to get the vehicle to move in neutral, drive, or reverse.

He said it should be a pretty easy fix though assuming that they have the part in stock.
K5 Optima Store is offline  
 
post #4 of 10 Old 06-14-2016, 03:58 PM
Super Moderator
 
Gene's Avatar
 
Join Date: Jul 2015
Posts: 365
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 83 Post(s)
Garage
Default

Have them change the light switch while they are at it
I had recall done on mine for multifunction switch SC130, and the start button SA228 while mine was being serviced.
All our parts, here in phoenix, come from the main warehouse in Calif. Hope it doesn't have to come from Korea
Gene is offline  
post #5 of 10 Old 06-14-2016, 04:52 PM Thread Starter
Senior Member
 
K5 Optima Store's Avatar
 
Join Date: Jun 2014
Location: Los Angeles, CA
Posts: 190
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage
Default

Quote:
Originally Posted by Gene View Post
Have them change the light switch while they are at it
I had recall done on mine for multifunction switch SC130, and the start button SA228 while mine was being serviced.
All our parts, here in phoenix, come from the main warehouse in Calif. Hope it doesn't have to come from Korea
Funny you mention that, I was one of the first to have that issue and so they replaced it for me about a month ago before the TSB was issued.

Now that the TSB came out, today they are going to replace the part with the new part that came out, replace the push start button and ring which I think is what you're referring too, and also the EPB module as well.

Just pisses me off that the car becomes unmovable right where it sits when that happens. Had the car half way out of my garage all night and day until they could come get it today. Never even heard of something like this happening before.
K5 Optima Store is offline  
post #6 of 10 Old 06-14-2016, 09:58 PM
Super Moderator
 
Gene's Avatar
 
Join Date: Jul 2015
Posts: 365
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 83 Post(s)
Garage
Default

That's the way I felt when I hit the pothole in North Carolina, right in front of a KIA dealership.
They couldn't touch the car. Had to wait for a dealership 35 miles away to make arrangements to have the car towed
then for them to fix it.
I live in Glendale,AZ and we were on our way to our daughters funeral.
They held up the funeral till we could get there
Gene is offline  
post #7 of 10 Old 06-15-2016, 02:06 PM
Member
 
Join Date: Nov 2015
Location: Pacific Northwest
Posts: 99
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Garage
Default

Thank you for the information, as my wife is the primary driver I could see here calling me frantically.

Its understandable that failure of the EPB is full on, annoying but understandable.

Question, did you activate the ESB and then could not release or did it just come on?

The only times I have had problems was when I activated it at a red light as when I wanted to go it would not release. Thankfully after a couple restarts it cleared and I was able to go.

This could be a major problem if in motion, freeway speeds could be catastrophic.

Ptrs
Current KIA's: '15 K9, '16 Soul EV
Ptrs is offline  
post #8 of 10 Old 06-17-2016, 04:12 AM Thread Starter
Senior Member
 
K5 Optima Store's Avatar
 
Join Date: Jun 2014
Location: Los Angeles, CA
Posts: 190
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Garage
Default

Quote:
Originally Posted by Gene View Post
That's the way I felt when I hit the pothole in North Carolina, right in front of a KIA dealership.
They couldn't touch the car. Had to wait for a dealership 35 miles away to make arrangements to have the car towed
then for them to fix it.
I live in Glendale,AZ and we were on our way to our daughters funeral.
They held up the funeral till we could get there
Yeah it sucks, but they gave me a 2016 Kia Cadenza base model, and **** this thing sucks. An Optima is nicer than this IMHO. (At least the base model anyways) Sticker shows it priced under $32,000.

Quote:
Originally Posted by Ptrs View Post
Thank you for the information, as my wife is the primary driver I could see here calling me frantically.

Its understandable that failure of the EPB is full on, annoying but understandable.

Question, did you activate the ESB and then could not release or did it just come on?

The only times I have had problems was when I activated it at a red light as when I wanted to go it would not release. Thankfully after a couple restarts it cleared and I was able to go.

This could be a major problem if in motion, freeway speeds could be catastrophic.
You're welcome. Nope didn't activate it at all, was pulling out of my driveway and boom out of nowhere like a boat dropping an anchor, I was stuck.
K5 Optima Store is offline  
post #9 of 10 Old 06-17-2016, 02:08 PM
Super Moderator
 
Gene's Avatar
 
Join Date: Jul 2015
Posts: 365
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 83 Post(s)
Garage
Default

You don't realize how good the K900 is till you go back to a Optima, or cadenza.
I don't mean to take away from either car , but the K900 is just so much better
To me anyway
Gene is offline  
post #10 of 10 Old 06-17-2016, 03:43 PM
Member
 
Join Date: Nov 2015
Location: Pacific Northwest
Posts: 99
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 19 Post(s)
Garage
Default

That's majorly scary, thankfully it was just in the driveway. IMO that would be something I'd report to NHTSA.
Ptrs is offline  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome